ATH
Status
Back
Maintenance
Updates
Completed 20 Oct at 11:00pm UTC.
Affected services
Website
Completed
Maintenance completed
Posted 20 Oct at 11:00pm UTC.
Started
Updates & Upgrades
Posted 20 Oct at 01:00am UTC.