Back
Maintenance

Database restart

Completed 7 Jan at 02:25am UTC.

Website
Updated

Completed.

Posted 7 Jan at 02:23pm UTC.
Completed

Maintenance completed

Posted 7 Jan at 02:25am UTC.
Started

Performing small DB optimizations.

Posted 7 Jan at 02:15am UTC.