Back
Maintenance

Server & Code Updates

Completed 9 Mar at 11:03am UTC.

Website IRC Announce
Completed

Done. All services up.

Posted 9 Mar at 11:03am UTC.
Updated

Almost done…

Posted 9 Mar at 10:53am UTC.
Updated

OS upgrade done. Now updating the UNIT3D software.

Posted 9 Mar at 09:36am UTC.
Started

We will be performing scheduled maintenance to upgrade our server operating system and the software. We appreciate your understanding.

Posted 9 Mar at 08:25am UTC.